Formulář ONZ / PRIHL

Formulář ONZ zobrazuje jednotlivá oznámení o nástupu do zaměstnání / skončení zaměstnání.

Formulář PRIHL zobrazuje jednotlivé přihlášky, odhlášky nemocenského pojištění zaměstnanců.

Formulář můžete vyvolat nad seznamem dávek. Formulář zobrazuje :

Můžete přepínat mezi zobrazením formuláře (jeden záznam) a seznamem (přehled všech záznamů). Přepínat lze kliknutím na záložce nebo volbou v menu Zobrazit.

Po jednotlivých listech se můžete pohybovat pomocí tlačítek v levém dolním rohu. Ve formuláři pomocí kláves PageUp (předchozí), PageDn (následující), Ctrl+PageUp (první),  Ctrl+PageDn (poslední). V seznamu šipkami nahoru, dolů.

Pokud vlevo od některé položky svítí vykřičník v červeném kolečku , je v této položce nějaká chyba. Pokud se postavíte myší nad vykřičník, zobrazí program popis chyby. Podle typu záznamu (přihláška, odhláška, změna, oprava, sběr) se mění skupina povinných položek. 

V rámečku nad výběrem typu je zobrazeno i číslo typu. Pro kontrolu, pokud při importu vstupují nepovolené hodnoty. V parametrech můžete nastavit, jaký typ se má nastavit v nově založeném záznamu.

Na mnohé položky je zapojen číselník. V parametrech úlohy můžete nastavit, zda chcete číselníky zapojit nebo ne a jak zobrazovat číselník států. Pomocí nastavení Výběr používaných států, můžete omezit obsah rozbalovacích seznamů nad položkami s vazbou na stát. Obsah všech číselníků si můžete prohlédnout v Nastavení / Číselníky.

Pokud položka s číselníkem nezobrazuje žádnou hodnotu a přesto kontrola hlásí nepovolenou hodnotu, můžete ji změnit výběrem jiné hodnoty z přípustných. Pokud chcete vidět hodnotu, můžete si na chvíli vypojit číselníky a tím si zobrazit obsah položky.

Můžete filtrovat zobrazované listy výběrem hodnoty v rozbalovací položce (vyber filtr). Dostanete se něj buď myší nebo klávesami Alt+L. Po výběru jedné z hodnot se aktivuje filtr. Změní se ukazatel počtu vět. Filtr může nabývat těchto hodnot :

Můžete vyhledávat list určitého zaměstnance. V rozbalovací položce v dolní části formuláře můžete nastavit, zda chcete hledat podle Příjmení, / Rodného čísla / Os.čísla. Zápisem znaků do další položky program potupně nastavuje na list kde zvolená položka začínající zadanými znaky, pokud takový existuje. Do položky pro hledání se dostanete buď myší nebo klávesami Alt+H.

Pokud máte právo a dávka je ve stavu Editace, můžete opravovat a měnit všechny údaje.

Setřídit data můžete pomocí menu Data / Setřídit podle... a vybrat z nabízených možností. V parametrech programu můžete nastavit, jak se mají data setřídit při otevření formuláře.  V seznamu navíc můžete setřídit kliknutím levým myši na záhlaví libovolného sloupce. První kliknutí setřídí vzestupně, druhé sestupně.

Nový list přidáte kliknutím na tlačítko + (plus) v dolní části formuláře nebo v menu Data / Přidat list. Pokud je v parametrech nastaveno, zobrazí se poté formulář Osobních údajů, ze kterého můžete vybrat zaměstnance a přenést jej do listu. Pokud v dávce není žádný záznam, jsou položky nepřístupné, musíte nejprve založit nový list a pak můžete vyplňovat položky.

Zrušit právě zobrazený list můžete stiskem tlačítka v dolní části formuláře nebo v menu Data volbou "Zrušit aktuální list / zrušit výběr".

Rušit podle značek a filtru můžete volbami menu : 

Kontrolu aktuálního listu můžete vyvolat tlačítkem Kontrola. Lze stisknout myší nebo vyvolat klávesami Alt+K.

Kliknutím do zaškrtávacího políčka můžete pro aktuální list nastavit značku. Značku lze nastavovat i hromadně pomocí menu Značky. Značku lze použít při :

Menu Data :

Menu Akce :

Z menu Tisk můžete vyvolat :